Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take part in the September Giveaway for a Spider Rear Rack and a Heavy Duty Drybag from aeroe


Single speed
#1
I have a GT Peace 29er
I have noticed a slipping feeling in the pedals when pedaling forward.
The crank and pedals seem tight
If I use a more firm pressure on pedals I do not feel it
But when I lighten the pressure on the pedals I feel it sort of slip
The chain is the correct tension It is a single speed 18t rear cog
Looks like it is the rear hub Maybe the pawls not engaging?

I have used a pressure washer after dirty riding Maybe that did it?

Do I need to remove and take apart the hub?
The bike is 4 months old

Any ideas?
  Reply
#2
You should contact your supplier, should be fixed under warrenty. Note if you start work yourself you will invalidate this.
  Reply
#3
Pressure washer is not good for a bike.
Nigel
  Reply


Possibly Related Threads...

Forum Jump:

[-]
10 Latest Posts
Front Derailer fails to shift to the big...
Today 06:12 AM
Raleigh "Trail" bike
Today 05:02 AM
Know about the Hercules?
Today 04:18 AM
Hello from North Carolina
Yesterday 10:06 PM
Pedals: Clip vs. Clipless
Yesterday 07:43 PM
90's Raleigh R600
Yesterday 06:21 PM
Proper way to torque a crank bolt on a s...
Yesterday 03:37 PM
Where are you from and What is your favo...
Yesterday 02:19 PM
Tour de France 2020
Yesterday 12:08 PM
Do Any Electric Bike Allows You to Switc...
09-18-2020 07:23 PM

[-]
Top 5 Posters This Month
no avatar 1. Jesper
36 posts
no avatar 2. G_M
14 posts
no avatar 3. Sagan97
10 posts
no avatar 4. Papa Dom
10 posts
no avatar 5. Painkiller
10 posts