Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take Part in the February Giveaway for a Chance to Win 2x METRO Hybrid Bikes


Single speed
#1
I have a GT Peace 29er
I have noticed a slipping feeling in the pedals when pedaling forward.
The crank and pedals seem tight
If I use a more firm pressure on pedals I do not feel it
But when I lighten the pressure on the pedals I feel it sort of slip
The chain is the correct tension It is a single speed 18t rear cog
Looks like it is the rear hub Maybe the pawls not engaging?

I have used a pressure washer after dirty riding Maybe that did it?

Do I need to remove and take apart the hub?
The bike is 4 months old

Any ideas?
  Reply
#2
You should contact your supplier, should be fixed under warrenty. Note if you start work yourself you will invalidate this.
  Reply
#3
Pressure washer is not good for a bike.
Nigel
  Reply


Possibly Related Threads...

Forum Jump:

[-]
10 Latest Posts
Flat Repair Tools
Yesterday 11:08 PM
New Wheel Question
Yesterday 10:54 PM
Please help! Identifying this ol' gal.
Yesterday 12:53 AM
1990 Specialized Rockhopper How to Fluff...
02-26-2024 10:07 PM
How to keep your bicycle safe?
02-26-2024 03:31 AM
Top 3 Bibshorts in terms of value
02-26-2024 03:07 AM
Why do spokes break?
02-25-2024 10:35 PM
New Wheel Question
02-25-2024 10:32 PM
Hello to all. I a just introducing mysel...
02-25-2024 10:29 PM
Chain sits on top of chainring when shif...
02-25-2024 10:16 PM

[-]
Join BikeRide on Strava
Feel free to join if you are on Strava: www.strava.com/clubs/bikeridecom

[-]
Top 5 Posters This Month
no avatar 1. GirishH
27 posts
no avatar 2. enkei
23 posts
no avatar 3. ReapThaWhirlwind
15 posts
no avatar 4. meamoantonio
14 posts
no avatar 5. Painkiller
13 posts