Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take part in the July Giveaway for an Electric Commuter Bike from KBO Bike


Single speed
#1
I have a GT Peace 29er
I have noticed a slipping feeling in the pedals when pedaling forward.
The crank and pedals seem tight
If I use a more firm pressure on pedals I do not feel it
But when I lighten the pressure on the pedals I feel it sort of slip
The chain is the correct tension It is a single speed 18t rear cog
Looks like it is the rear hub Maybe the pawls not engaging?

I have used a pressure washer after dirty riding Maybe that did it?

Do I need to remove and take apart the hub?
The bike is 4 months old

Any ideas?
  Reply
#2
You should contact your supplier, should be fixed under warrenty. Note if you start work yourself you will invalidate this.
  Reply
#3
Pressure washer is not good for a bike.
Nigel
  Reply


Possibly Related Threads...

Forum Jump:

[-]
10 Latest Posts
Sling Cycles Tagati
Today 07:10 AM
What are your best biking places in your...
Today 07:00 AM
One expensive lock vs two cheaper locks?
Today 02:12 AM
Question about Leg Shaving
Today 01:26 AM
Hallo..
Today 12:40 AM
COLNAGO SUPER (unknown year)
Yesterday 10:36 PM
Hello
Yesterday 12:44 PM
Hi
Yesterday 10:17 AM
Shifter Doesn't Have Clicking Sound
Yesterday 12:01 AM
Looking for reliable bikes for gf and me...
07-22-2021 09:03 PM

[-]
Top 5 Posters This Month
no avatar 1. Jesper
32 posts
no avatar 2. ReapThaWhirlwind
11 posts
no avatar 3. JR Namida
9 posts
no avatar 4. Zviedrs
6 posts
no avatar 5. Papa Dom
5 posts