Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take part in the August Giveaway for a brand new Street Bicycle Core Line fixed gear bike


New 3 speed hub with coaster brake: brake squeals and sticks
#1
I recently purchased a used (nearly new) Sun Traditional adult Tricycle, 2016  model, and attempted to add on a brand new 3 speed conversion kit purchased through Amazon. The kit is made by Sturmey Archer, and intended for Sun trikes like mine from 2015 and newer.

As far as I can tell, I've installed the hub correctly. It shifts smoothly and runs well.

However, the coaster brake makes a weird squealing noise when applied, and often sticks a bit.

Here is a link to a short video, shot through the rear basket. First i cycle through all gears, then demonstrate the weird noise it makes when the brake is applied. Higher speed = louder noise, and more sticking when I resume pedaling.  

https://youtu.be/kRiYaPo6F_0

It does not make the noise when I test the hub and brake by lifting the rear wheel and turn the pedals with the other hand, but only when I ride. Fwiw, I'm a thin person,  and the trike fits me just fine, so I'm not "overstressing" the brake with my own weight.

Does anyone have any idea if this could be a defective hub, or if I've made an installation error? I'm hoping to avoid visiting the local bike shop, in order to save some money, but will do so if needed.

I certainly appreciate any help offered.

Thanks!
Laura
  Reply
#2
(08-01-2017, 12:14 PM)unusualhuman Wrote:  I recently purchased a used (nearly new) Sun Traditional adult Tricycle, 2016  model, and attempted to add on a brand new 3 speed conversion kit purchased through Amazon. The kit is made by Sturmey Archer, and intended for Sun trikes like mine from 2015 and newer.

As far as I can tell, I've installed the hub correctly. It shifts smoothly and runs well.

However, the coaster brake makes a weird squealing noise when applied, and often sticks a bit.

Here is a link to a short video, shot through the rear basket. First i cycle through all gears, then demonstrate the weird noise it makes when the brake is applied. Higher speed = louder noise, and more sticking when I resume pedaling.  
https://hghreviewer.com/

It does not make the noise when I test the hub and brake by lifting the rear wheel and turn the pedals with the other hand, but only when I ride. Fwiw, I'm a thin person,  and the trike fits me just fine, so I'm not "overstressing" the brake with my own weight.

Does anyone have any idea if this could be a defective hub, or if I've made an installation error? I'm hoping to avoid visiting the local bike shop, in order to save some money, but will do so if needed.

I certainly appreciate any help offered.

Thanks!
Laura

Nice kit, have u made it by your self ? Or u just bought it ?!!
  Reply


Possibly Related Threads...
Thread
Author
Replies
Views
Last Post
Question
358
08-01-2020, 08:12 AM
Last Post: Jesper
 
369
06-06-2020, 03:20 AM
Last Post: jonsio
 
547
05-04-2020, 07:55 AM
Last Post: G_M
 
403
02-27-2020, 07:55 PM
Last Post: BaBaBiker
 
899
01-13-2020, 03:17 PM
Last Post: dwc7

Forum Jump:

[-]
10 Latest Posts
Hey everyone
Yesterday 11:42 PM
State Bicycle Core Line | August 2020
Yesterday 02:45 PM
Freewheel hub wiggling in place + Chain ...
Yesterday 09:26 AM
clicking new chain
Yesterday 09:13 AM
One side of V brake doesn't spring back
Yesterday 09:10 AM
From Henderson Nevada
Yesterday 06:31 AM
Primary care
Yesterday 02:36 AM
Back on the bike in Wales
08-06-2020 09:13 AM
Moulton MK3 1970s
08-06-2020 06:48 AM
2020 road cycling season
08-05-2020 07:16 PM

[-]
Top 5 Posters This Month
no avatar 1. Jesper
53 posts
no avatar 2. Painkiller
15 posts
no avatar 3. CharleyFarley
12 posts
no avatar 4. Papa Dom
7 posts
no avatar 5. RoadRacer2020
5 posts