Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take part in the April Giveaway for an Electric Bicycle Roadster V2 from Ride1UP


New 3 speed hub with coaster brake: brake squeals and sticks
#1
I recently purchased a used (nearly new) Sun Traditional adult Tricycle, 2016  model, and attempted to add on a brand new 3 speed conversion kit purchased through Amazon. The kit is made by Sturmey Archer, and intended for Sun trikes like mine from 2015 and newer.

As far as I can tell, I've installed the hub correctly. It shifts smoothly and runs well.

However, the coaster brake makes a weird squealing noise when applied, and often sticks a bit.

Here is a link to a short video, shot through the rear basket. First i cycle through all gears, then demonstrate the weird noise it makes when the brake is applied. Higher speed = louder noise, and more sticking when I resume pedaling.  

https://youtu.be/kRiYaPo6F_0

It does not make the noise when I test the hub and brake by lifting the rear wheel and turn the pedals with the other hand, but only when I ride. Fwiw, I'm a thin person,  and the trike fits me just fine, so I'm not "overstressing" the brake with my own weight.

Does anyone have any idea if this could be a defective hub, or if I've made an installation error? I'm hoping to avoid visiting the local bike shop, in order to save some money, but will do so if needed.

I certainly appreciate any help offered.

Thanks!
Laura
  Reply
#2
(08-01-2017, 12:14 PM)unusualhuman Wrote:  I recently purchased a used (nearly new) Sun Traditional adult Tricycle, 2016  model, and attempted to add on a brand new 3 speed conversion kit purchased through Amazon. The kit is made by Sturmey Archer, and intended for Sun trikes like mine from 2015 and newer.

As far as I can tell, I've installed the hub correctly. It shifts smoothly and runs well.

However, the coaster brake makes a weird squealing noise when applied, and often sticks a bit.

Here is a link to a short video, shot through the rear basket. First i cycle through all gears, then demonstrate the weird noise it makes when the brake is applied. Higher speed = louder noise, and more sticking when I resume pedaling.  
https://hghreviewer.com/

It does not make the noise when I test the hub and brake by lifting the rear wheel and turn the pedals with the other hand, but only when I ride. Fwiw, I'm a thin person,  and the trike fits me just fine, so I'm not "overstressing" the brake with my own weight.

Does anyone have any idea if this could be a defective hub, or if I've made an installation error? I'm hoping to avoid visiting the local bike shop, in order to save some money, but will do so if needed.

I certainly appreciate any help offered.

Thanks!
Laura

Nice kit, have u made it by your self ? Or u just bought it ?!!
  Reply


Possibly Related Threads...
Thread
Author
Replies
Views
Last Post
 
353
04-16-2021, 10:05 PM
Last Post: Jesper
 
471
11-29-2020, 11:28 AM
Last Post: Jeff L
 
706
11-18-2020, 04:06 AM
Last Post: Jesper
 
1,057
08-18-2020, 08:11 PM
Last Post: mtnbikeracer76
Question
811
08-01-2020, 08:12 AM
Last Post: Jesper
 
694
06-06-2020, 03:20 AM
Last Post: jonsio

Forum Jump:

[-]
10 Latest Posts
Rattling cassette
Today 11:07 AM
FILM: 358 mi: Bike Trip from Pittsburgh ...
Yesterday 01:33 PM
What’s the name of this bottom bracket ?
Yesterday 09:03 AM
Hi folks!
Yesterday 07:28 AM
2021 Pro Road Cycling
Yesterday 06:09 AM
Bicycle Day
Yesterday 04:56 AM
Is Dunlop valve almost the same as Prest...
04-20-2021 08:49 PM
How many people ride everyday?
04-19-2021 05:34 PM
Are electric bikes the future?
04-19-2021 04:26 PM
Can you help me identifying this Gitane?
04-17-2021 01:24 AM

[-]
Top 5 Posters This Month
no avatar 1. Jesper
14 posts
no avatar 2. Papa Dom
5 posts
no avatar 3. Mark Zucker
5 posts
no avatar 4. J_R_Schultz
4 posts
no avatar 5. BaBaBiker
3 posts