Have questions or want to discuss cycling? Join Now or Sign In to participate in the BikeRide community.

New: Take part in the July Giveaway for an Electric Commuter Bike from KBO Bike


FSA K-Force crank w/MegaEXO BB; noise
#1
Alright, so I have a FSA K-force crank with a MegaEXO BB 68mm width, and it clicks certain times while riding, and I feel the click up through my feet and so forth. Sometimes the click is so loud other riders can here it and ask what it is. I have done a lot of trouble shooting to see if it might be something else, pedals, drivetrain, etc. It is not those, it is the bottom bracket crank combo. If I clean and lube the crank and BB interface areas, as specified, the click goes away for a short while; 20-30 miles, then starts up again. I have even ran the bike with a Dura Ace 7900 BB that I have and I get the exact same noise and sensation. I have used an Octa-Link BB and crank with great success, no clicking or nocking or noise of any kind. I have decided to ride the Octa-Link BB and crank for now. But, does anyone have any thoughts or input as to what may be causing the click, nock with the MegaEXO, Hollowtech? Also, I've had many other people complain of similar issues with MegaEXO, Hollowtech, GXP, BB30 bottom brackets. Is it perhaps some design flaw? Any input appreciated. Thanks.
  Reply
#2
I too have this problem
Have only done about 2 - 3000 km and feels/sounds like the Beeb has had it.

Im trying to figure out If I can use a Shimano 105 BB 5700 model but it is a little difficult to be sure

Oh I wish Sheldon was still around!
  Reply


Possibly Related Threads...
Thread
Author
Replies
Views
Last Post
 
17,516
07-19-2021, 12:00 AM
Last Post: rbx
 
707
05-03-2020, 08:44 PM
Last Post: quinnrj
 
3,899
08-11-2014, 12:03 PM
Last Post: jacke
 
4,397
05-20-2014, 02:57 PM
Last Post: DaveM
 
20,563
05-15-2013, 01:48 PM
Last Post: BlackStar

Forum Jump: